PDA

View Full Version : Home and Auto Anyone here handy with 2 stroke engines (moped)


Tylerthigpen!1!
02-15-2010, 11:45 PM
I bought a moped this past weekend. Mainly for the sex appeal but also I needed a little something to get around campus on. Anyways I decided to go cheap and I bought one that doesnt work.
Little bit of info on it:
2007 Eton Beamer
The previous owner said it sat for a couple months without fuel stabilizer and now it wont start.
It has spark and compression
It has a vacuum operated petcock (fuel valve). I tested this and it does work.
It has some oil leaking from the oil line into the engine. Not much but worth mentioning
The fuel filter has been replaced as the gas has also been completely drained
The attached picture is of the manual choke. The red circle is where a crack has developed in the rubber. Could this be a problem?


Since it was sitting so long and it had spark/compression, I decided to clean the carb. Pre rebuild I wasnt getting any vacuum going to the fuel petcock from the carb. After digging into the carb (18mm mikuni), I find a bunch of little black rubber specks. They look like the aftermath of an eraser. Probably from the fuel line. And the fuel bowl gasket is in two pieces. I got the gasket to fit back on just because it sits in a indention. Anyways I use liberal amounts of carb cleaner while cleaning it. I was sure to remove all the jets and what have you. I put all the adjustment screws back in the same tightness they came out. So I throw here back on the moped and try firing it up. No dice. I still dont have any vacuum going to the petcock valve. I'm stumped. I think it might be either the
a) manual choke
b) fuel bowl gasket
c)fuel lines (black rubber in carb)
d) no frickin clue.

Anybody got some feedback for me? Any gay moped jokes?

Frazod
02-15-2010, 11:47 PM
It's too late at night to find the man card picture. But you already know it's been revoked. :D

Tylerthigpen!1!
02-15-2010, 11:48 PM
If it makes you feel better, the guy I bought it from painted it to match his mullet mobile (87 t-tops camaro).

Tylerthigpen!1!
02-15-2010, 11:49 PM
Just white though. No flames or shit like that.

RustShack
02-15-2010, 11:49 PM
I had a moped, when it wouldn't start I would put a few drops of gas in the whole where the air filter is then it would fire right up. Does it even have a carbiratior? I'm not sure how these newer mopeds work.

Tylerthigpen!1!
02-15-2010, 11:51 PM
I had a moped, when it wouldn't start I would put a few drops of gas in the whole where the air filter is then it would fire right up. Does it even have a carbiratior? I'm not sure how these newer mopeds work.

Yea you were putting gas straight into the carb. A carb just breaks the gas into a fine mist so it is combustible. They've been around for a bit. I havent had a chance to put gas straight into the engine. It is back at my parents' house in kc. I was rushed this weekend to try and get it to work.

RustShack
02-15-2010, 11:53 PM
I know I was putting my gas into the carb. I was asking if yours has one because I know they aren't in cars anymore and my moped was old school.

stumppy
02-15-2010, 11:54 PM
I'm not sure if I've messed with one of those or not. I've had to deal with my fair share of carb problems , mainly because everything I own is old and worn out or someone gives me their old worn out crap.
Anyways, does it have a vacumn operated fuel/accelarator pump ? Whenever I have cleaned one inside and out and it still doesn't start thats the next place I look.

googlegoogle
02-15-2010, 11:58 PM
Check list.

1. spark ?

2. Air?

3. fuel?

4. Carb screws ?

Maybe take it apart again. 2x the charm.

http://www.youtube.com/watch?v=4D4Cde7VYB0

Tylerthigpen!1!
02-15-2010, 11:59 PM
I know I was putting my gas into the carb. I was asking if yours has one because I know they aren't in cars anymore and my moped was old school.

Ah gotcha my bad. Yea mine has a carb.

Tylerthigpen!1!
02-16-2010, 12:00 AM
I'm not sure if I've messed with one of those or not. I've had to deal with my fair share of carb problems , mainly because everything I own is old and worn out or someone gives me their old worn out crap.
Anyways, does it have a vacumn operated fuel/accelarator pump ? Whenever I have cleaned one inside and out and it still doesn't start thats the next place I look.

Yea it has a vacuum fuel pump. I cleaned it. Seems to work when I take the hose off the carb and manually give it some vacuum.

RustShack
02-16-2010, 12:02 AM
I would just try putting some gas in there that way it should get it started then burn the crap in there out.

Tylerthigpen!1!
02-16-2010, 12:08 AM
I would just try putting some gas in there that way it should get it started then burn the crap in there out.

How much gas did you put in and how? Just a syringe or something of the sort?

stumppy
02-16-2010, 12:09 AM
Yea it has a vacuum fuel pump. I cleaned it. Seems to work when I take the hose off the carb and manually give it some vacuum.

If it's one of the diaghram type it might move back and forth with vacumn but still not pump fuel. One small hole is all it takes. I'd be looking at the fuel bowl gasket again. That may be where you're losing vacumn/prime.

Oh yea, starting fluid will help alot when diagnosing suspected fuel probs.

RustShack
02-16-2010, 12:12 AM
How much gas did you put in and how? Just a syringe or something of the sort?

I was watching someone fix my moped and he put gas in a spray bottle himself and got it going that way with a spray or two. When I did it myself I pretty much just stuck a straw in my gas tank put my finger over the end and released it in the filter hole.

Phobia
02-16-2010, 12:18 AM
It has spark and compression
It has a vacuum operated petcock (fuel valve). I tested this and it does work.
Well, you're 66.667% there. What is it missing then?

Tylerthigpen!1!
02-16-2010, 12:22 AM
Well, you're 66.667% there. What is it missing then?

Fuel. But the thing is I can't get the vacuum line from the carb to the petcock valve to work.

Phobia
02-16-2010, 12:23 AM
You said the valve worked. You're missing oxygen based on what I'm reading.

Tylerthigpen!1!
02-16-2010, 12:27 AM
You said the valve worked. You're missing oxygen based on what I'm reading.

Well it works I am the one applying the vacuum. The carb is not applying any vacuum.

dtebbe
02-16-2010, 01:01 AM
I would replace the vacuum petcock (which is basically a fuel pump) the diaphragm probably got hard. Also go to your local mower shop and buy some good quality Tygon fuel line and replace all of the fuel line, and clean the carb out again. Your fuel line is rotting away and once you get it running will clog up the carb, lean out the air/fuel mixture and stick you engine.

The ethanol that is in today's pump gas is really hard on diaphragms and rubber parts.

DT

Here is a site that seems to have the valve:
http://www.scootsusa.com/fuel-valve-vacuum-fuel-pump-p-109.html

googlegoogle
02-16-2010, 01:06 AM
I would replace the vacuum petcock (which is basically a fuel pump) the diaphragm probably got hard. Also go to your local mower shop and buy some good quality Tygon fuel line and replace all of the fuel line, and clean the carb out again. Your fuel line is rotting away and once you get it running will clog up the carb, lean out the air/fuel mixture and stick you engine.

The ethanol that is in today's pump gas is really hard on diaphragms and rubber parts.

DT

Here is a site that seems to have the valve:
http://www.scootsusa.com/fuel-valve-vacuum-fuel-pump-p-109.html

he said the petcock works. I would find the problem first before buying parts.

googlegoogle
02-16-2010, 01:11 AM
Black particles? 2:34 mark. clogged jet.

<object width="425" height="344"><param name="movie" value="http://www.youtube.com/v/4D4Cde7VYB0&hl=en_US&fs=1&"></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><embed src="http://www.youtube.com/v/4D4Cde7VYB0&hl=en_US&fs=1&" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="425" height="344"></embed></object>

Over-Head
02-16-2010, 02:13 AM
If it makes you feel better, the guy I bought it from painted it to match his mullet mobile (87 t-tops camaro).

Try this

http://www.youtube.com/watch?v=gh1RUUMhPxM

Won't help get your man card back, but it will make ya laugh :D

JOhn
02-16-2010, 02:36 AM
It's too late at night to find the man card picture. But you already know it's been revoked. :D

here

JD10367
02-16-2010, 09:54 AM
I stopped reading after the first line about buying a moped for the sex appeal. LMAO

I would replace the vacuum petcock (which is basically a fuel pump) the diaphragm probably got hard.

I don't know why, but that sentence aroused me. :D